Portable build framework for OpenNTPD
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
Brent Cook cc3292981b add 6.7 changes, update format to match LibreSSL 1 year ago
compat support SOCK_CLOEXEC on macOS 4 years ago
include Provide fallback definition for __packed 2 years ago
m4 add -lresolv on Linux 1 year ago
patches disable broken rdomain support for FreeBSD 1 year ago
scripts update autoconf scripts 4 years ago
src Add constraint_reset() stub when libtls is not available 1 year ago
.gitignore pull default ntpd.conf from openbsd source 4 years ago
.travis.yml add travis config 6 years ago
AUTHORS Move credits from README to AUTHORS. 6 years ago
COPYING new OpenNTPD portable tree 6 years ago
ChangeLog add 6.7 changes, update format to match LibreSSL 1 year ago
INSTALL move to README.md, update platform list 1 year ago
Makefile.am move to README.md, update platform list 1 year ago
OPENBSD_BRANCH add infrastructure for checking out branches 6 years ago
README.md move to README.md, update platform list 1 year ago
VERSION add log.h, bump version 1 year ago
autogen.sh sync autogen.sh with LibreSSL, cache upstream config scripts 5 years ago
configure.ac compat updates, add recallocarray and freezero 4 years ago
dist.sh consolidate patches, cleanup dist.sh 6 years ago
update.sh add log.h, bump version 1 year ago

README.md

This is the portable version of OpenBSD's native Network Time Protocol daemon, OpenNTPD http://www.openntpd.org/

Platform Requirements

  • adjtime(2) and settimeofday(2) syscalls or equivalent.
  • adjfreq(2) or an equivalent compatibility function for best results
  • daemon(3), setresgid(2), setresuid(2) or equivalent
  • a working arc4random(2) implementation (this project shares the same arc4random compatibility code from LibreSSL)
  • libtls from LibreSSL 3.0+ is required for HTTPS time constraint validation.

Supported Operating Systems

OpenNTPD may work on other operating systems, newer and older, but the above ones are tested most recently by the developer. At the time of writing, OpenNTPD portable is known to build and work on:

  • OpenBSD (6.7)
  • Linux (Debian 10+, Ubuntu 18.04+)
  • FreeBSD (12+)
  • MacOS (10.13+)

Reports (success or otherwise) are welcome. You may report bugs or submit pull requests at the GitHub project: https://github.com/openntpd-portable