Use system-wide Wine, DXVK & D9VK for Steam Play/Proton (Windows) games directly from Linux Steam client
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 

22 lines
575 B

# Maintainer: Pekka Helenius <fincer89 [at] hotmail [dot] com>
pkgname=lib32-steamlibs
pkgver=4.2
pkgrel=1
pkgdesc='Proprietary Valve Steam client libraries for Wine (Proton)'
arch=('x86_64')
url='https://steampowered.com/'
license=('custom')
depends=('wine' 'steam')
source=(
'libsteam_api.so'
'steam.exe.so'
)
md5sums=('2b8113a13ad8409c916492b8b7cb061c'
'7c269269b9e3de1f780d7be81f910ba7')
package() {
mkdir -p "${pkgdir}/usr/lib32/wine"
install -Dm 644 -t "$pkgdir/usr/lib32/" libsteam_api.so
install -Dm 755 -t "$pkgdir/usr/lib32/wine/" steam.exe.so
}